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WHAT IS FIJI AND HOW TO GET IT?  

Fiji is and open-source image processing and analysis software, it can be downloaded from here: 

https://imagej.net/software/fiji/downloads. More detailed information about the usage of Fiji and tutorials, please 

check the Fiji Wiki pages: https://imagej.net/.  

Download Fiji and extract it according to the instructions on the https://imagej.net/software/fiji/downloads site. If 

working on PC do not store Fiji in programme files. Start Fiji from the Fiji/ImageJ icon. The software will ask if you 

want to update the software – select Yes, please. Restart Fiji.  

HOW TO OPEN IMAGES?  

Open the software and click File -> Open. Choose the file from your computer and click ok. Images can also be 

dragged and dropped from folder directly to Fiji. 

HOW TO DUPLICATE IMAGES? 

It is good practice to always start with duplication of your original image and work with the duplicate. That way 

you don’t accidentally override the original image.  

1. Open sample image ”20x nucleus_high contrast” from the course package 

2. Select image and click Shift + d 

HOW TO EDIT THE BRIGHTNESS AND CONTRAST?  

1. Select the image you just duplicated and choose: Image -> Adjust -> Brightness/Contrast. You will get a pop-up 

window with possibility to set the minimum and maximum gray values, the brightness, and the contrast. Auto 

will give you settings that the software thinks are the best; it applies an intelligent contrast. 

2. If the Auto button does not produce a desirable result, use the region-of-interest (ROI) tool to select part of the 

cell and some background and click Auto. The stretch will then be based on the intensities of the ROI. 

3. You can further modify the values by moving the bars. This can be done each channel separately.  

4. The Reset button sets the values that were in the image when opened.  

5. The true values from 0-255 (8-bit images) or 4095 (12-bit images) can be set manually from Set button.  

6. Remember to consider if you want to click Apply. Pressing the Apply button permanently changes the actual 

grey values of the image. If you are analyzing image intensity do not press this button. 

GAMMA 

Gamma performs a non-linear histogram adjustment. If you have very faint images, you can enhance the lowest 

intensities with using gamma correction. Editing of gamma is considered image manipulation and is not generally 

accepted. If you must use gamma correction, you must mention it in the materials and methods. 

Process -> Math -> Gamma... 

https://imagej.net/software/fiji/downloads
https://imagej.net/
https://imagej.net/software/fiji/downloads
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IMAGE DIMENSIONS  

An image can consist of pixel elements = pixels. Typically, they form a two-dimensional matrix. Images can also 

have additional dimensions, typically in microscope images there is z-dimension, time, and channels.    

1. Open sample image ”PC3 stack” from the course package. 

2. View the dimensions at the top of the image. 

 

3. View different dimensions by using the scrolling bars below the image.  

4. Channels can be controlled through the Channels tool: Image › Color › Channels Tool... 

5. If you want to change a channel color, change the Look up Table (LUT): Image -> Lookup Tables 

HOW TO VIEW CHANNELS?  

You can easily toggle channels by using the the channels slider below the image. You can also turn channels on or 

off using the channels tool Image › Color › Channels Tool... . Composite means that channels are overlayed.  

HOW TO SPLIT AND MERGE CHANNELS? 

Splitting of channels is needed for example when you want to delete a certain channel. Merging might be 

necessary when you want to prepare the image for publication or presentation. 

1. Open sample image ”PC3 stack” from the course package 

2. Split the channels: Image -> Color -> Split channels 

3. Merge channels: Image -> Color -> Merge channels. You can choose the color for each channel. Remember to 

choose Ignore source LUT if you want to change the colors. You can also keep the source images 

(recommended), so that you can then redo the merging in case something goes wrong. 

4. You create a regular or a composite merge image. The regular will merge the three channels and create an RGB-

image. The composite image will keep all three channels separate, and it can be again split: Image -> Color -> 

Split channels. RGB images can be spilt to three channels (with reservations!): Image -> Type -> RGB Stack 
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INTENSITY PROJECTIONS  

Intensity projection are a way to visualize 3D stacks in one plane. For example maximum intensity projection 

creates an image in which pixels contain the maximum intensity value of all images in the stack at the pixel 

location. Only in special cases maximum intensity projections are recommended for analysis.  

1. Continue with one channel from ”PC3 stack” from the course package 

2.  Image -> Stacks -> Z-project… 

3. You can choose from which slide to start and finish. This way unwanted frames can be removed.   

4. What other projection types can you find? 

IMAGE SUB-SETTING  

Sometimes an image needs to be rescaled.  

1. Open sample image ”20x nucleus_high contrast” from the course package 

2.  Image -> Scale… 

3. Choose the scale in x-, y- or z-dimensions, 1 means the original, 0.5 is half of width in pixels (x and y) or number 

of slices (in z). Alternatively, you can also decide the exact pixel amount in x and y and the number of layers in z.  

4. Try which interpolation methods looks best with your image.  

5. You can use averaging when downsizing if needed.  

6. It is recommended to create a new window (Shift + d). This way the original will also stay open and if you are 

not happy with the result, the settings can be redefined from the original image. 

7. Last, choose a name for your file and click Ok.  

8. Examine how this affected the image size and dimensions.  

IMAGE CALIBRATION 

It is important that the image file is handled properly by the and the size of the image calibrated, ImageJ doesn’t 

always read the files properly. You can see if your image is calibrated from the from the info bar at the top of the 

image. If the image is calibrated, there will be μm or some other spatial unit next to the numbers. If the image is 

NOT spatially calibrated, the dimension will be labelled "pixels". 

 

1. Open sample image ”20x nucleus_high contrast” from the course package 

2. Go to Image -> Properties to see the image settings 

3. Check that the number of channels, slices, and frames match. 

4. Check your unit of length and set it to μm (um) or nm 
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5. Check your pixel width and height (can be usually retrieved from the metadata Image -> Show info… Look for 

PhysicalSizeX. The units are in μm.) 

6. Go to Image -> Properties and change the pixel size  

7. In 2D images the voxel depth can be ignored 

8. Click Ok. 

 

If you know the size of a feature (for example, a previously applied scale bar) you can use that to apply a 

calibration. In most image analysis software, it is possible to draw a line along the length of the known feature or 

scale bar and define the length and unit of the line and then apply that to the whole image. In ImageJ: 

1. Using the line selection tool, draw a line along the length of the feature or scale bar. 

2. Run the menu command Analyze -> Set scale… 

3. Enter the dimensions of the object/scale bar in the “known distance” box and set the units in the "Unit of 

length" box. 

4. Do not check Global unless you want all your images to have this calibration. Click OK. 



 
IMAGE HANDLING USING IMAGEJ / FIJI | © Joanna Pylvänäinen 2025  | 

HOW TO ADD A SCALE BAR  

1. Continue with image ”20x nucleus_high contrast” from the course package 

2. Go to Analyze -> Set Scale and make sure that your image is calibrated and that the unit of length is set to µm. 

Click Ok. 

3. 2.   Go to Analyze -> Tools -> Scale bar. Set the length of the scale bar (in µm) and other settings if needed. If you 

intend to safe the image in tiff format, remember to untick the overlay box. It will create another image layer. If 

savings jpeg, you can leave the box ticked, the layer will be merged with the image when exporting. Click Ok. 

Note! Remember to do all the other modifications (e.g., merging/adjusting brightness and contrast/maximum 

projection) first and add the scale bar to the final image before exporting. 

HOW DRAW ON THE IMAGE  

To draw a line or a box on the image use the line or rectangle ROI tool from the toolbar. To stamp the line or box 

click Edit -> Draw (shortcut: d). If you're drawing the ROI on a stack, you'll be asked if you want to process all of the 

slices. Choosing 'yes' will draw the ROI on every slice while choosing 'no' will result in the ROI only being added to 

the current frame. If you use 8-bit etc images the line color will be defied by your LUT max value (in grayscale color 

will be white). If you want a colorful line or a box, the image must be first transformed into RGB image Image -> 

Type -> RGB Color, the color is determined by the color picker toolbar button. By double clicking the color picker 

button you will get a color palette. The width of the line in pixels is defined in Edit -> Options -> Line width. The line 

width must be determined before it is drawn on the image. 

Adding text is done with the toolbar’s text button. Double click on the button to set the font, font style, 

justification, font color, background color, font size and angle that the writing will be. Antialiasing can also be 

turned on/off here. Click the toolbar, click the image, and write the desired text. To stamp the text to the image 

click Edit -> Draw (shortcut: d). 

Adding an arrow can be done by first adding the arrow drawing tool to ImageJ tool bar: Image -> Annotate -> 

Arrow. Select the arrow tool and start drawing it in an image. By double clicking the arrow button it is possible to 

edit the arrow. The color can be edited Edit -> Options -> Colors -> Foreground color and line width can be edited 

Edit -> Options -> Line width. The Foreground option in the latter will change the color of the arrow. To stamp the 

arrow to the image click Edit -> Draw (shortcut: d). 

IMAGE TYPE CONVERSION 

1. Converting to 8-bit from 16-bit: Image -> Type -> 8-bit 

2. Converting to RGB: Image -> Type -> RGB Color 

Note! Pay attention to the image bit depth. Regular image viewer programs (power point, paint, preview) are not 

able to read images with large bit depths. If the size of the image is 16bit, it must be converted to an 8-bit (Image -

> Type -> 8-bit) or RGB (Image -> Type -> RGB Color) image before saving. 

 

 



 
IMAGE HANDLING USING IMAGEJ / FIJI | © Joanna Pylvänäinen 2025  | 

IMAGE SAVING AND EXPORTING  

1. Saving images: File -> Save as -> tiff/jpeg….  

Saving images for storage: always keep the original image data and if possible, the whole image processing and 

analysis workflow (macro etc). It is generally recommended to work on a duplicate of your original data to avoid 

any possible loss of data.  

Saving images for publication: each journal has or at least should have their own image guidelines, that should be 

strictly followed. It is recommended to develop a workflow that is flexible and can handle a variety of formatting 

rules, such as 300dpi or 600dpi, raster or vector, margins, or no margins. Generally, decisions affecting the final 

figure should be set back in the workflow as far as possible so that starting the image editing from scratch is not 

necessary. The final figure files that are provided to the journal editor will be further processed regarding of where 

the image will be published (online/print). It might not be possible to control the figure quality loss at the journal, 

but it is possible to make sure that the files given to them are as high-quality as possible.  

Exporting images for screens: When exporting for screens the actual screen pixels should be considered instead of 

dpi. Almost every monitor in the world consists of at least 1024 x 768 pixels – some monitors some are bigger, and 

can show you more. Most monitors are set at 72 dpi. That means if you took out a ruler and held it up to your 

monitor, each inch would have 72 little dots of light. Regardless of how many inches and how much resolution your 

image has, most of the time images that appear on web pages are going to expand or shrink to be 72dpi. If you 

were to view a 600 dpi image on the screen, your monitor will basically decide which 72 dots in each inch would 

best represent the 600 that are really there. Therefore, having higher resolution for PowerPoint or web graphics 

will do you no good – it will just make your slides or pages larger and they take longer to load.  

High quality images are great for PowerPoint presentations, but they make file sizes huge. For most screens, a 

normal sized image (10 cm x 15 cm) at 150 dpi should be sufficient. 

HOW TO USE THE 3D-VIEWER 

2. Open sample image ” PC3 stack” from the course package 

3. Do any adjustments and merging needed first (split, merge, adjust brightness…) 

4. When your image is looking good, go to 3d-viewer: Plugins -> 3D viewer 

5. Choose suitable settings for your purpose and click Ok. 

6. Show coordinates or surrounding box: Edit -> Show… Make sure that Show contents is ticked. This shows your 

image. 

7. Practice a little how the viewer responses to mouse movements. 

8. You can take a snapshot of the view: View -> Take snapshot 

9. When you are ready to do recording go to View -> Start Freehand Recording 

10.  Move the image to your preference. 

11.  When ready go to View -> Stop Freehand Recording 

12.  You can now play the movie in a new window (first rendering is slow). 
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13.  Exporting: File -> Save as -> AVI… 

14.  Choose compression (PGN is generally good for online publishing) and frame speed (24 fps the universally 

accepted film frame rate).  

15.  Choose saving location and you’re done! 

SEGMENTATION AND PARTICLE ANALYSIS  

Image segmentation is the classification of pixels in an image as “pixels of interest” vs “background”. Separating a 

digital image into multiple segments. Assigning a label to every pixel in an image so that pixels with the same label 

share certain visual characteristics. Thresholding is the most common method to segment.  -> results a binarized 

image 

Global thresholding works by choosing a general cut-off value. Works well if all portions of the image have same 

quality and signal to noise/background, and all particles/objects have similar signal levels.  

Local thresholding is computed for each pixel according to the image characteristics within a window of radius r 

around it 

To try thresholding, try the auto-threshold plugin. It gives an overview of different thresholding methods. (This 

plugin binarizes 8 and 16-bit images using various global thresholding methods.) 

NOTE: For historical reasons, ImageJ was setup to analyze dark particles on white background. Most analysis these 

days is of fluorescent particles/organelles on black background! This (still!) creates some problems during 

workflows, as IJ needs to know whether to aggregate bright or dark pixels for particle detection. -Re-set by Process 

-> binary -> options-> “black backg”. Always check image LUT during workflow! - some commands invert LUTs for 

display purposes. In the next exercise, LUT is inverted...check! -to “re-invert” LUT: image -> Look Up Tables -> 

invert LUT. (* inverting LUT is NOT the same as inverting image - it doesn’t affect gray levels!) 
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EXAMPLE 1: SIMPLE LINE MEASUREMENT 

To measure a distance in ImageJ, you can use the straight line tool. Make sure that your image is correctly 

calibrated first. 

1. Select the straight line tool 

2. Draw a line across the desired distance 

3. Read the length of the line below to ImageJ toolbar or click m from your keyboard to print the result. 

You can also read the last coordinate of the line as well as the angle from the same place.  
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EXAMPLE 2: MEASURE THE SIZE DISTRIBUTION OF NUCLEI 

1. Open sample image ” 20x nucleus_high contrast” from the course package 

2. Open image & check properties (LUT state: Process -> binary -> options…) 

3. Check if image has been calibrated Image -> Properties. If not, calibrate image (see Image calibration). 

4. Segment Image -> Adjust -> Autothreshold…   

5. Choose best thresholding algorithm Image -> Adjust -> Threshold. If the selection is wrong, tick Dark 

background. Don’t click “apply”- it will change image into binary! 

6. Setting the measurement parameters before measuring Analyze -> Set Measurements 

o Size - area, centroid, perimeter, Feret & “shape descriptors”... 

o Content - (gray values): mean, stdDev, minMax, mode… 

o Others… 

o Shape Descriptors: 

o Circ.(circularity): (4π*area/perimeter^2) 1.0 = perfect circle. Values may be unusable for small 
particles (few pixels)! 

o AR(aspect ratio, Fit Ellipse): the ratio of the width to the height of an ROI 

o Feret'sDiameter- Longest distance inside ROI/particle (aka “maximum caliper”). Includes also 
Angle (0-180 degrees) to horizontal. MinFeret= diameter perpendicular to mid Feret 

o Integrated Density- The sum of the values of the pixels in the image or selection. 

o Read more: https://imagej.nih.gov/ij/docs/guide/146-30.html 

7. Analyze & add to ROI manager Analyze -> Analyze Particles… (“Filter size”: 20-Infinity & Circularity: 0.5-1.0 -

Display...Clear...add To...Exclude...Include... Why use these options? See here: 

https://imagej.nih.gov/ij/docs/guide/146-30.html) 

8. Check distribution of measured parameters: from results window: Results -> Distribution…  

9. Save results from results window: File -> Save As… 

10. You can do simple plotting using the Results table: Results -> Plot… How does the area of nucleus affect its 

roundness? You can fit the data by using Data >> button from the Plot of results -window. 

 

 

 

 

 

 

https://imagej.nih.gov/ij/docs/guide/146-30.html
https://imagej.nih.gov/ij/docs/guide/146-30.html
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EXAMPLE 3: MEASURE THE SIZE DISTRIBUTION OF NUCLEI USING STARDIST 

If you have an image with low contrast, it is not possible to segment it easily using the above-mentioned 

workflow. StarDist is an ImageJ/Fiji plugin for a cell/nuclei detection for microscopy images. The plugin can be 

used to apply already trained models to new images. Currently, the plugin only supports 2D image data.  

Documentation: https://imagej.net/StarDist  and https://github.com/mpicbg-csbd/stardist 

StarDist needs to be installed on your Fiji. Help - > Update… . an update window will open. Click Manage update 

sites -button and select StarDist and CSBDeep from the list. Click Close and then Apply changes. Downloading 

starts. When done, restart Fiji.  

11. Open sample image ”20x nucleus_low contrast” from the course package 

12. Adjust brigthenss and contrast, split channels and calibrate image if needed. 

13. Try segmentation using the tools form Example 1 – what do you observe? 

14. Start the plugin from Plugins -> StarDist -> StarDist 2D, dialog window opens. 

15. Select a neural network model from the dropdown list, Versatile (fluorescent nuclei) works the best in this 

case 

16. Adjust the postprocessing parameters 

o Probability/Score Threshold - higher values lead to fewer segmented objects, but will likely 

avoid false positives. Default setting 0.50 works well, you can try others. 

o Overlap Threshold - higher values allow segmented objects to overlap substantially. Default 

setting 0.40 works well, you can try others. 

o The segmented objects can be returned as a Label Image or in the ROI Manager (or both). 

17. Click Ok. 

18. Analyze -> Analyze Particles… you can use the same parameters as in the Example 1 (“Filter size”: 20-Infinity 

& Circularity: 0.5-1.0 -Display...Clear...add To...Exclude...Include...) 

19. Check distribution of measured parameters: from results window Results -> Distribution…  

20. Try different plotting options> from results window Results -> Plot… 

 

 

 

 

 

https://imagej.net/StarDist
https://github.com/mpicbg-csbd/stardist
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EXAMPLE 4: MEASURE SIGNAL INTENSITY IN NUCLEI 

Continue from part 7. from the Example 1: 

21.  You have now all the objects in the ROI manager. Click Measure on the left – you will get a table of results.  

22. Save results table File -> Save As… 

23. To view the ROIs on the original image, open your thresholding options again Image -> Adjust -> Threshold 

and hit Reset. 

24. To save generate an image with the ROIs and original image on the background click Flatten on the ROI 

manager. If you are unhappy with the ROIs, you can change them in Properties… in the ROI manager. 

 

 

EXAMPLE 5: MEASURE SIGNAL INTENSITY OTHER CHANNEL 

Continue form part 18 in example 2: 

25. Once you have your ROIs in the manager activate the image with nuclei. Click Measure on the ROI manager. 

You get a result table with the values selected.  

26. To get the values from the other window, select it. Untick and tick again the box Show all in the ROI manager. 

Click Measure. 
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